SAP Knowledge Base Article - Public

3759479 - Warning Message Blocks Saving Process for Payment Information in Latest People Profile

Symptom

  • In Latest People Profile, creating a new Payment Information record shows warning messages and prevents the record from saving.
  • Warning messages displayed:

"Are you sure you want to proceed with the update? If yes, double check your entry and click Proceed."

"Do you wish to continue?"

Environment

SAP SuccessFactors Employee Central

Reproducing the Issue

  1. Open a user’s People Profile.
  2. Go to Personal Data > Payment Information and add a new record.
  3. Fill all mandatory fields (including country-specific fields) and click Save.
  4. When the two warning dialogs appear, click on "Ok" to continue.
  5. Warning message occurs again, and the system does not allow saving the record.

Cause

Warning message is treated as a blocking error instead of being suppressed.

Resolution

The fix for this issue is planned to be deployed with the patch 2605p7. For patch timelines, please review SAP SuccessFactors Patches Knowledge Base

Keywords

ppx, people profile, payment information, bank information, cannot save, warning dialog, proceed warning, warning message, unable to save, warning, loop, do you wish to continue, prefer header, handling=lenient, save blocked, create new payment information, country-specific validation, patch p7, employee central, PTCH-50176 , KBA , LOD-SF-EC-PAY , Payment Information (Bank Information) , Known Error

Product

SAP SuccessFactors Employee Central all versions