SAP Knowledge Base Article - Public

3760245 - AttachmentExistsIndicator not exposed to OData Service

Symptom

In the OWL of Tickets there is a field named as "Attachment Exists" (AttachmentExistsIndicator). Is desired to know if this field can be used in OData collection for Service Request.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to General Settings > OData Service Explorer
  2. Open OData collection ServiceRequest
  3. The field AttachmentExistsIndicator is not there

Cause

The Attachment Exists (AttachmentExistsIndicator) field is not available for usage in service OData.

Resolution

This is the system expected behavior.

If the feature/functionality is required urgently, please refer to KBA 3475641 - Functionality Currently not Available. 

Keywords

service, service request, odata, tickets, AttachmentExistsIndicator, attachment, usage, exposed, collection, c4c, not possible, unable, not able, cannot, can't, not shown, not displayed, not visible , KBA , LOD-CRM-SRP , Service Request Processing , LOD-CRM-INT-API , OData API (C4C Only) , Problem

Product

SAP Cloud for Customer core applications all versions