Symptom
- In Configuration Transport Center, selecting Configuration Area “Platform” and clicking Go returns no configuration types.
- The following on-screen message is displayed on the left-hand side tree: No search results found. Please change the filter options and try again.
Environment
SAP SuccessFactors HCM Suite
Reproducing the Issue
- Go to Configuration Transport Center.
- In the Configuration Area dropdown, select “Platform”.
- Click “Go”.
- Observe that no configuration types are listed.
Cause
- Configuration Transport Center (CTC) uses the dot (.) as the path separator in its configuration hierarchy.
- If any relevant SuccessFactors object code/externalCode (for example, a picklist code) contains dots, the resulting CTC path becomes ambiguous and the search/listing for that configuration will not work.
- This is an expected design constraint: externalCodes used with CTC must not contain dots.
Resolution
- Identify all picklists in Picklist Center whose code contains a dot (.).
-
Update each affected picklist code by replacing dots with underscores (_) or other supported characters. There is no need to modify the picklist name, as dots in names are allowed.
-
Save the changes.
-
Re-run the search in Configuration Transport Center using Configuration Area = "Platform" and verify whether the issue is resolved.
See Also
- SAP Help Portal Searching Configurations in Configuration Transport Center
Keywords
ctc, configuration transport center, platform, configuration types not listed, empty list, no results after go, picklist code, externalcode dot, dot separator, path separator, underscores, transport, No search results found. Please change the filter options and try again. , KBA , LOD-SF-PLT-CGC , Configuration Center , Problem
SAP Knowledge Base Article - Public