SAP Knowledge Base Article - Public

3761861 - Cannot Set Supplier Reconciliation Account When Creating Supplier Invoices via API (S/4HANA Cloud Public Edition)

Symptom

  • Users cannot specify an Accounts Payable reconciliation account when creating supplier invoices via API.

Environment

  • Product: SAP S/4HANA Cloud Public Edition
  • Fiori UI for Invoice Verification (Public Cloud)

*** The Updated value: ***

  • Product: SAP S/4HANA Cloud Public Edition
  • Fiori UI for Invoice Verification (Public Cloud)

Reproducing the Issue

  1. Use the OData v2 service API_SUPPLIERINVOICE_PROCESS_SRV or the SOAP service SupplierInvoice_In to create a supplier invoice.
  2. Attempt to provide or select the Accounts Payable reconciliation account in the request payload.
  3. Observe that no input field exists for the reconciliation account in either API.

Cause

 The field "ReconciliationAccount" exists on the header entity "A_SupplierInvoiceType"

Resolution

  • Configure the allowed alternative reconciliation accounts in SSCUI 102631.
  • Include "ReconciliationAccount": "XXXXXX" as a header-level field in your POST payload to A_SupplierInvoice

See Also

Keywords

supplier invoice api, reconciliation account, ap reconciliation, api_supplierinvoice_process_srv, supplierinvoice_in, odata v2, soap, glaccount item, missing field, not supported by design, f0859, new supplier invoice app, accounts payable subledger, create supplier invoice via api, s/4hana cloud public edition*** The Updated value: ***supplier invoice api, reconciliation account, accounts payable, api_supplierinvoice_process_srv, odata v2, soap SupplierInvoice_In, glaccount, manage substitution app, invoice posting, abap cloud, f0859, new supplier invoice app, payable subledger, s/4hana cloud public edition , KBA , MM-FIO-IV-2CL , Fiori UI for Invoice Verification (Public Cloud) , Problem

Product

SAP S/4HANA Cloud Public Edition all versions