SAP Knowledge Base Article - Preview

3779298 - Metrics Reporting Stops and OData Sync Fails with HTTP 400 “Metering Service Is Required for application” After an SSAM Upgrade - SAP Service and Asset Manager

Symptom

  • Metrics collection stops after decommissioning the previous SAP Service and Asset Manager (SSAM) version.
  • Scheduled jobs for sending metrics fail; no payloads are sent to cloud.
  • In table /SMFND/D_SAPPROD, field HAS_METER_SERV is not set to “X” for the active SSAM application.
  • Report /MFND/CORE_CLOUD_METRICS_PROG shows: “Meter Flag Deactivated in Table /SMFND/D_SAPPROD for App: SAP_SERVICE_ASSET_MANAGER_2410. Measure Counts Not Reported.”
  • OData sync returns HTTP 400: “A metering service is required for application SAP_SERVICE_ASSET_MANAGER_2511.”


Read more...

Environment

SAP Service and Asset Manager

Product

SAP Service and Asset Manager all versions

Keywords

ssam, metrics, metering, /mfnd/core_cloud_metrics_prog, has_meter_serv, /smfnd/d_sapprod, middleware server, additional properties, x-api-key, service_path, mobile services, rfc destination, slg1, http 400, odata sync , KBA , MOB-APP-SAM , SAP Service and Asset Manager , Problem

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP for Me (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.