Symptom
- When loading item descriptions via Item Connector, values where HTML_CPNT_DESC is exactly 4000 bytes fail to load with below error message
- Error message: "Length of Column exceeds specified length. HTML_CPNT_DESC"
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Learning
Reproducing the Issue
- Prepare an Item Connector feed file where the HTML_CPNT_DESC content is exactly 4000 bytes.
- Run the Item Connector to load the item.
- Observe that the load fails with a length Error Message : " Length of Column exceeds Max. specified length. HTML_CPNT_DESC "
Cause
The character limit currently support 4000-7 when uploading HTML_CPNT_DESC via connector
Resolution
- For the beautification we are adding this extra "<p></p>" tag for the HTML_CPNT_DESC content which is why we are getting error when adding exactly 4000 character bytes in this case.
- While adding html description for an item we are adding <p></p> to exact content so this need to be adjusted to specified max length supported for html description.
- Ideally 4000-7 = 3993 so 3993 character should be added.
- Update and re-upload the connector feed file with the reduced description length to 3993 character
- Re-run the Item Connector and confirm the item loads without the length error.
See Also
Keywords
HTML_CPNT_DESC, item connector, 4000 bytes, length exceeds specified length, description limit, html description, p tag insertion, auto html tags, connector failure, lms, successfactors learning, item description, field length exceeded, beautification tags, load error , KBA , LOD-SF-LMS-CON , Connectors , LOD-SF-LMS-ITE , Items , Problem
Product
SAP SuccessFactors Learning all versions
SAP Knowledge Base Article - Public