SAP Knowledge Base Article - Preview

3791844 - Deployment fails during database initialization with error “Failed to initialize password for the 'admin' user” due to password policy violation

Symptom

During a deployment with database initialization in SAP Commerce Cloud, the deployment fails at the Initialize Database step.

The deployment log contains errors similar to the following:

Caused by: de.hybris.platform.core.initialization.SystemSetupException: Failed to initialize password for the 'admin' user. Reason: Invalid password entered. Please ensure it meets the password guidelines and try again. Set property 'initialpassword.admin' to correct value.

The issue is commonly observed in newly provisioned environments or when performing the first deployment with initialization.


Read more...

Environment

SAP Commerce Cloud in the Public Cloud

Product

SAP Commerce Cloud all versions

Keywords

CCv2, deployment failed, Initialize Database, admin password, Initialpassword.admin, PasswordPolicyViolationException, DefaultUserInitializer, Invalid password entered, password policy, regex , KBA , CEC-SCC-CLA-DEP , Deployments , Problem

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP for Me (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.