Symptom
- During CMS installation, connection validation fails on the "Configure CMS Repository Database" screen
- After the 64-bit ODBC DSN for the CMS database is selected, clicking Next returns the error:
"The system cannot verify the database logon information." - Getting below error from dbcheck traces :
2026 08 04 09:56:27:964|(..\ODBCDatabase.cpp:165) ODBC error found: ErrorMessage([Microsoft][ODBC Driver 18 for SQL Server][SQL Server]The specified schema name "XYZ" either does not exist or you do not have permission to use it.), ErrorCode(2760)
2026 08 04 09:56:27:964|(TransactionManager.cpp:160) DBConnectionHolder - Caught retryable error with Code 2760, Msg: [Microsoft][ODBC Driver 18 for SQL Server][SQL Server]The specified schema name "XYZ" either does not exist or you do not have permission to use it.. Number of retryable errors on connection 1 is 1 (at DatabaseSubsystem_impl.cpp:3177).
2026 08 04 09:56:27:964|(TransactionManager.cpp:56) Transaction failed. Disconnecting from database
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Read more...
Environment
- SAP BusinessObjects Business Intelligence 2025
- Windows
- MS SQL Server 2022
Product
Keywords
Schema,INS00104,CMS,DSN , KBA , BI-BIP-INS , Installation, Updates, Upgrade, Patching , Problem
About this page
This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP for Me (Login required).Search for additional results
Visit SAP Support Portal's SAP Notes and KBA Search.
SAP Knowledge Base Article - Preview