SAP Knowledge Base Article - Preview

3793742 - Enterprise Portal: Intermittent "Portal runtime error" (HTTP 500) in Application Integrator iViews due to UME cache/UserMappingNotAvailableException

Symptom

  • Intermittent “Portal runtime error” occurs when launching application integration iViews in Enterprise Portal. 
  • Issue reproduces randomly across supported browsers.
  • On-screen message: 
    Portal runtime error.
    An exception occurred while processing your request. Send the exception ID to your portal administrator.
    Exception ID: hh:mm_dd/mm/yy_2334_<node_id>
    See log file for details about this exception
  • Network trace shows HTTP 500 response to requests to /irj/servlet/prt/portal/prtroot/pcd!3aportal_content...
  • DefaultTrace contains the following entries:
    • #2.0#<TimeStamp>#+0800#Error#com.sap.security.core.umap.imp.UserMapping#
      #BC-JAS-SEC-UME#com.sap.security.core.sda#C0000AB680541575000000000000058C#173250951000000004#sap.com/com.sap.portal.appintegrator.sap#com.sap.security.core.umap.imp.UserMapping.getMasterKey()#<USER>#1052##11A3E3A26F9011F1C1EA00000A539987#8d0cceed6f8b11f1afe900000a539987##0#Thread[HTTP Worker [@1958417098],5,Dedicated_Application_Thread]#Plain##
      A user mapping method is called which requires that user mapping has been initialized (i.e. told about a potentially existing cryptographic master key), but user mapping initialization has not been performed yet.
      [EXCEPTION]
      com.sap.security.api.umap.UserMappingNotAvailableException: A user mapping method is called which requires that user mapping has been initialized (i.e. told about a potentially existing cryptographic master key), but user mapping initialization has not been performed yet.
    • #2.0#<TimeStamp>#+0800#Error#com.sap.portal.prt.connection#
      #EP-PIN-PRT#tc~epbc~prtc~api#C0000AB680541576000000020000058C#173250951000000004#sap.com/irj#com.sap.portal.prt.connection#<USER>#1052##11A3E3A26F9011F1C1EA00000A539987#8d1091cc6f8b11f198b900000a539987##0#Thread[HTTP Worker [@1481949961],5,Dedicated_Application_Thread]#Plain##
      Exception ID:<EXCEPTION_ID>
      [EXCEPTION]
      com.sapportals.portal.prt.component.PortalComponentException: Error in service call of Portal Component
      Application name : com.sap.portal.appintegrator.sap
      Component : <Component>
      Component class : com.sapportals.portal.sapapplication.SAPApplicationIntegratorComponent
      User :<USER>
    • Caused by: com.sapportals.portal.prt.runtime.PortalRuntimeException: Exception in SAP Application Integrator occured: Exception occured in layer WebDynpro/ABAPSSOLayer
    • Caused by: com.sapportals.portal.appintegrator.ApplicationIntegratorException: Exception occured in layer WebDynpro/ABAPSSOLayer
    • Caused by: com.sap.security.api.umap.UserMappingNotAvailableException: A user mapping method is called which requires that user mapping has been initialized (i.e. told about a potentially existing cryptographic master key), but user mapping initialization has not been performed yet.


Read more...

Environment

  • SAP NetWeaver Application Server for Java
  • SAP Enterprise Portal
  • User Management Engine (UME)

Product

SAP Enterprise Portal all versions ; SAP NetWeaver Application Server for Java all versions

Keywords

portal runtime error, enterprise portal, intermittent, http 500, UserMappingNotAvailableException, UME cache, user mapping, web dynpro abap sso, application integrator, defaultTrace, exception id, webdynpro 500 internal server error , KBA , BC-JAS-SEC-UME , User Management Engine , EP-PIN-PRT , Portal Runtime , EP-PIN-NAV , Navigation , Problem

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP for Me (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.