SAP Knowledge Base Article - Preview

3793829 - C4C Outbound Messages Fail With Error 'HTTP Code: 500 ( Internal Server Error )'

Symptom

All outbound SOAP messages in SAP Cloud for Customer (C4C) towards the same external system fail with error 'HTTP Code: 500 ( Internal Server Error )'.

In SAP Cloud Integration (CPI), the corresponding iFlow messages fail with an error similar to this:

org.apache.cxf.binding.soap.SoapFault: Error reading XMLStreamReader: Unexpected character 'j' (code 106) in prolog; expected '<'
at [row,col {unknown-source}]: [1,1], cause: com.ctc.wstx.exc.WstxUnexpectedCharException: Unexpected character 'j' (code 106) in prolog; expected '<'
at [row,col {unknown-source}]: [1,1]


Read more...

Environment

  • SAP Cloud for Customer v1
  • SAP Cloud Integration
  • SAP Cloud Connector
  • SAP ERP
  • SAP S/4HANA

Product

SAP Cloud for Customer add-ins 2025 ; SAP Cloud for Customer core applications 2505 ; SAP Cloud for Customer core applications 2508 ; SAP Cloud for Customer integration with SAP ERP all versions ; SAP Cloud for Customer integration with SAP S/4HANA all versions ; SAP S/4HANA Cloud Public Edition all versions

Keywords

C4C, CPI, ERP, S4, 500 internal server, Unexpected character, PKIX, propagation, SSL, certificate , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , Problem

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP for Me (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.