SAP Knowledge Base Article - Preview

3793868 - [CamelJdbcAdapter] Snowflake key-pair connection fails with "Illegal character in url" - SAP HANA Smart Data Integration

Symptom

  • Connection to Snowflake via CamelJdbcAdapter (or Generic JDBC in SAP Datasphere) fails when using key-pair authentication with an encrypted private key
  • private_key_file_pwd is included directly in the JDBC URL, and the password contains one or more special characters (for example: $, @, #, %, +, &)
  • The following entries appear in the DP Agent logs:
    • SnowflakeConnectString | JDK14Logger.logInternal [] - Exception thrown while parsing Snowflake connect string. Illegal character in url.


Read more...

Environment

SAP HANA smart data integration 2.0

Product

SAP HANA smart data integration 2.0

Keywords

CamelJdbcAdapter, Snowflake, key-pair, key pair, private_key_file_pwd, private key password, illegal character, URL encoding, special character, dollar sign, dollar, JDBC URL, SnowflakeDriver, SDI, Data Provisioning Agent, DPAgent , KBA , HAN-DP-SDI , SAP HANA smart data integration (SDI) , Problem

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP for Me (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.