SAP Knowledge Base Article - Preview

3793888 - Task with ABAP dataflow fails with error "The SAP job was canceled for host <XXXXX>, job name <XXXXX>, job count <XXXXX>" – SAP Cloud Integration for data services

Symptom

  • A CI-DS task with an ABAP dataflow fails with the following error message:
    • 2026-08-08 14:57:10       (R)(1599128:1585424064)R3C-150605      |Data flow XXXXX|Reader XXXXX|Transform XXXXX The SAP job was canceled for host < >, job name <XXXXX XX/XX/XX XX:XX:XX>, job count <XXXXX>, job   log from SAP <    XX.XX.XXXX   XX:XX:XX    Job XXXXX XXXXX started XX.XX.XXXXX   XX:XX:XX    Step 001 started (program XXXXX, variant &0000000000000, user ID XXXXX) XX.XX.XXXX   XX:XX:XX    Internal session terminated with a runtime error RAISE_EXCEPTION (see ST22) XX.XX.XXXX   XX:XX:XX    Job canceled >.
  • ST22 logs show:
    • Error RFCIO_ERROR_SYSERROR in /bas/916_REL/src/krn/rfc/abrfcpic.c : 1891
      CPIC-CALL: 'ThSAPOCMINIT', communication rc: CM_PARAMETER_ERROR (cmRc=19), taskhandler rc: GW_SNC_START_EXT_DIS (thRc=730)
      Not allowed to start non-SNC connections
      DEST =SAPDS
      HOST =%%RFCSERVER%%
      PROG =SAPDS_XXXXX
      GWHOST =XXXXX
      GWSERV =3300
  • ST11 logs show:
    • ERROR       SNC disabled to start insecure programs, reject request
  • In the source S/4HANA system:
    • Flag snc/permit_insecure_start is set to 0.
    • Flag snc/only_encrypted is set to 1.


, job name , job count " – SAP Cloud Integration for data services"> Read more...

Environment

SAP Cloud Integration for data services

Product

SAP Cloud Integration for data services all versions

Keywords

RFC_COMMUNICATION_FAILURE, SERVER_NOT_REGISTERED, registration not allowed, gateway rc 720, SAPDS, RFC server program, reginfo, secinfo, SNC, non-SNC connections, ABAP dataflow, execute in background, batch job, CI-DS, SAP Gateway , KBA , LOD-HCI-DS , HANA Cloud Integration for Data Services , Problem

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP for Me (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.