Symptom
- Remote table replication fails with a memory error such as:
- internal error: Error opening the cursor for the remote database [...] cannot allocate enough memory: [9] Memory allocation failed; $failure_type$=STATEMENT_MEMORY_LIMIT_FROM_GLOBAL_CONFIG
- Partitions have been defined on the remote table, and individual explicit partitions complete successfully
- Replication fails at the last step, which processes a large volume of data
- Reviewing the DP Agent framework trace shows that while the defined partitions process little to no data, an additional partition is being processed in a single query without a restrictive WHERE clause
Read more...
Environment
SAP HANA smart data integration
Product
SAP HANA smart data integration 2.0
Keywords
remote table, replication, memory, OOM, out of memory, STATEMENT_MEMORY_LIMIT, default partition, partition, partitioning, SDI, HanaAdapter, ABAPAdapter, Datasphere , KBA , HAN-DP-SDI , SAP HANA smart data integration (SDI) , Problem
About this page
This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP for Me (Login required).Search for additional results
Visit SAP Support Portal's SAP Notes and KBA Search.
SAP Knowledge Base Article - Preview