SAP Knowledge Base Article - Preview

3794062 - AS Java - UserAdmin (/useradmin) returns HTTP 500 due to RUNAS user authorization failure

Symptom

1] The User Administration (UserAdmin) application in the SAP NetWeaver AS Java system is not accessible.
2] Error: HTTP 500 – Internal Server Error

Error in default trace: -

500 Internal Server Error is returned for HTTP request [http://<host>:<port>/useradmin/userAdminServlet ]:
  component [WDRedirectServlet],
  web module [useradmin],
  application [sap.com/com.sap.security.core.admin],
  DC name [sap.com/com.sap.security.core.admin],
  CSN component[BC-JAS-SEC-UME],

[EXCEPTION]
com.sap.engine.services.servlets_jsp.server.exceptions.WebServletException: Error occurred while servlet [WDRedirectServlet] is initializing with a run-as identity.
    at com.sap.engine.services.servlets_jsp.server.application.WebComponents.getServlet(WebComponents.java:894)
    at com.sap.engine.services.servlets_jsp.server.HttpHandlerImpl.runServlet(HttpHandlerImpl.java:385)
Caused by: java.security.PrivilegedActionException: javax.servlet.ServletException: com.sap.security.api.UMException: Initializing locking helper failed: The user does not have permission: applocking, Action: logical_locking_create
    
Caused by: javax.servlet.ServletException: com.sap.security.api.UMException: Initializing locking helper failed: The user does not have permission: applocking, Action: logical_locking_create
  
Caused by: com.sap.security.api.UMException: Initializing locking helper failed: The user does not have permission: applocking, Action: logical_locking_create
    
Caused by: java.lang.SecurityException: The user does not have permission: applocking, Action: logical_locking_create
    
Caused by: java.lang.SecurityException: User "RUNAS_<>" is not authorized.

Caused by: java.security.AccessControlException: No authorization


Read more...

Environment

  • NWA 7.5

Product

SAP NetWeaver 7.5

Keywords

UME, applocking, logical_locking_create, WDRedirectServlet, RUNAS_<>, run-as identity, com.sap.security.core.admin, BC-JAS-SEC-UME, UMException, Initializing locking helper failed, useradmin, userAdminServlet, SecurityException, No authorization, AccessControlException, 500 Internal Server Error, run-as user authorization, Locking service permission, safety_user  , KBA , BC-JAS-SEC-UME , User Management Engine , Problem

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP for Me (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.