Symptom
- During the "Preparation for downtime" phase of a SUM DMO (DMOV2S4) upgrade, the target database FQDN was changed after SUM input was provided.
- The shadow system does not start and work logs show:
*** ERROR => Connect to database failed, rc=1, rcSQL=-10709
[dbhdbconnect 654]
C SQLCODE : -10709
C SQLERRTEXT : Connection failed (RTE:[89001] Cannot resolve host name 'old target database fqdn' rc=11001: No \
C such host is known. (old target database fqdn:30441)) - The SAPDBHOST parameter was updated to the new FQDN under Profiles, yet the process still attempts to use the old FQDN.
Read more...
Environment
- SAP S/4HANA (any release)
- Software Update Manager (SUM)
- SUM with Database Migration Option (DMO)
Product
SAP NetWeaver Application Server for ABAP all versions ; SAP S/4HANA all versions ; software logistics toolset all versions
Keywords
sum, dodmo, dmov2s4, preparation for downtime, cannot resolve host name, rte 89001, rc 11001, sqlerrtext connection failed, hostname change, fqdn change, hdbuserstore, shadow system, sapdbhost, hana connection, upgrade failure, DMO, rcSQL=-10709, Connect to database failed , KBA , BC-UPG-TLS-TLA , Upgrade tools for ABAP , Problem
About this page
This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP for Me (Login required).Search for additional results
Visit SAP Support Portal's SAP Notes and KBA Search.
SAP Knowledge Base Article - Preview