Symptom
While updating XSA, the upgrade failed with below error:
In hdbinst_xs.log ::
INFO: Summary of critical errors
ERR : Installation failed
ERR : error installing
ERR : Cannot install
ERR : Custom event postInstall failed
ERR : Start instance 00 on master host 'wbscmdvpdb01' (worker, xs_worker) failed.
ERR : FAIL: The following processes are not running:
ERR : hdbxscontroller HDB XS Controller
ERR : Check the log file for SAP HANA Database error messages
In xscontroller.out::
.. FAILED!
Initialization failed: java.lang.UnsatisfiedLinkError: /tmp/bc-fips-jni_1551296181910361/libbc-probe.so: /tmp/bc-fips-jni_1551296181910361/libbc-probe.so: failed to map segment from shared object
FAILED to start: FAILED to startup the controller
Read more...
Environment
HANA Platform Edition 2.0
SAP HANA Extended Application Services, Advanced Model
Product
Keywords
update, XSA, failed, HDB, XS Controller, map, segment, shared library, noexec, tmp , KBA , BC-XS-RT , XS Advanced Runtime / XS Controller , Problem
About this page
This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP for Me (Login required).Search for additional results
Visit SAP Support Portal's SAP Notes and KBA Search.
SAP Knowledge Base Article - Preview