Symptom
- Standby Replication server log reporting:
...
E. 2026/08/14 02:05:35. ERROR #1028 DSI EXEC(107(1) SID_Site2.DB) - neric/dsi/dsiqmint.c(5381)
Message from server: Message: 16325, State 84, Severity 15 -- 'Cannot GRANT/REVOKE permission 'MANAGE ANY USER'. Verify that the granular permissions option is enabled, and grantor's 'granular permissions' login attribute value is not set to 'off'.
'.
H. 2026/08/14 02:05:35. THREAD FATAL ERROR #5049 DSI EXEC(107(1) SID_Site2.DB) - neric/dsi/dsiqmint.c(5394)
The DSI thread for database 'SID_Site2.DB' is being shutdown. DSI received data server error #16325 which is mapped to STOP_REPLICATION. See logged data server errors for more information. The data server error was caused by output command #0 mapped from input command #0 of the failed transaction.
H. 2026/08/14 02:05:35. THREAD FATAL ERROR #5273 DSI EXEC(107(1) SID_Site2.DB) - neric/dsi/dsiqmint.c(5422)
To write the failed transaction into log, please execute 'sysadmin log_first_tran, SID_Site2, DB'. Please analyze the transaction and provide an appropriate fix based on your analysis, then resume the connection.
I. 2026/08/14 02:05:35. The DSI thread for database 'SID_Site2.DB' is shutdown.
... - sap_status path:
...
Site1.Site2.DB State Suspended Path is suspended (DSI). Transactions are not being replicated.
Site1.Site2.DB Failing Command Error Message Failing Command Error Message The DSI connection in the Replication Server on the Site2 host to 'SID_Site2.DB' is suspended.
Site1.Site2.DB Latency Time 2026-08-14 01:46:47.380 Time latency last calculated
Site1.Site2.DB Latency 6020 Latency (ms)
Site1.Site2.DB Commit Time 2026-08-14 11:59:42.206 Time last commit replicated
Site1.Site2.DB Distribution Path Site2 The path of Replication Server through which transactions travel.
Site1.Site2.DB Drain Status Not Applicable The drain status of the transaction logs of the primary database server.
...
Read more...
Environment
- SAP Replication Server (SRS) 16.0
- SAP Adaptive Server Enterprise (ASE) 16.0 with Always-on Option (HADR)
- SAP Adaptive Server Enterprise (ASE) 16.0 with High Availability Disaster Recovery (HADR) for Business Suite
Product
SAP Adaptive Server Enterprise 16.0 ; SAP Replication Server 16.0
Keywords
HADR, 16325, GRANT, REVOKE, granular permissions , KBA , BC-SYB-REP-SAP , Replication with SAP Suite / SAP BW , Problem
About this page
This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP for Me (Login required).Search for additional results
Visit SAP Support Portal's SAP Notes and KBA Search.
SAP Knowledge Base Article - Preview