SAP Knowledge Base Article - Preview

3795328 - The property ccv2.platform.tomcat.serverxml.maxHttpHeaderSize appears to be ignored in SAP Commerce Cloud

Symptom

  • HTTP 400 errors occur while navigating the ecommerce portal.
  • A CDN receives a bad response from the backend due to exceeding cookie header size.
  • The error persists even after setting ccv2.platform.tomcat.serverxml.maxHttpHeaderSize to 24576.
  • Error message: "Request header is too large".


Read more...

Environment

  • SAP Commerce Cloud
  • Platform

Product

SAP Commerce Cloud all versions

Keywords

http 400, request header is too large, maxhttpheadersize, tomcat, server.xml, header size limit, cookie header size, 8 kb, 24 kb, ccv2.platform.tomcat.serverxml.maxHttpHeaderSize, ccv2, sap commerce cloud, cdn, header too large, template override , KBA , CEC-SCC-PLA-PL , Platform , Problem

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP for Me (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.