Symptom
After update to SP35 accessing NWA-->Configuration-->"Trusted Systems" throws the below error while updating the Certificate/Adding Trusted System:
- 500 Internal Server Error
- Failed to process request. Please contact your system administrator.
In DefaultTrace:
500 Internal Server Error is returned for HTTP request [https:/<hostname>:<port>/webdynpro/resources/sap.com/tc~lm~itsam~ui~mainframe~wd/FloorPlanApp]:
component [dispatcher],
web module [webdynpro/resources/sap.com/tc~lm~itsam~ui~mainframe~wd],
application [sap.com/tc~lm~itsam~ui~mainframe~wd],
DC name [],
CSN component[],
problem categorization [],
internal categorization [].
[EXCEPTION]
java.lang.IllegalAccessError: tried to access field com.sap.engine.services.keystore.impl.security.CodeBasedSecurityConnector.domains (class loader service:keystore@63685, resolved service:keystore@63685) from class com.sap.security.auth.sso2.wizard.impl.SSO2Impl (class loader sap.com/tc~sec~auth~sso2~wizard@785906)
at com.sap.security.auth.sso2.wizard.impl.SSO2Impl.makeSLDAvailable(SSO2Impl.java:116)
[..]
at com.sap.security.auth.sso2.wizard.impl.SSO2Impl.makeSLDAvailable(SSO2Impl.java:116)
at com.sap.security.auth.sso2.wizard.wdp.SSO2Wizard.loadSLD(SSO2Wizard.java:658)
at com.sap.security.auth.sso2.wizard.wdp.wdp.InternalSSO2Wizard.loadSLD(InternalSSO2Wizard.java:338)
at com.sap.security.auth.sso2.wizard.wdp.ConnectionView.wdDoInit(ConnectionView.java:117)
at com.sap.security.auth.sso2.wizard.wdp.wdp.InternalConnectionView.wdDoInit(InternalConnectionView.java:202)
at com.sap.tc.webdynpro.progmodel.generation.DelegatingView.doInit(DelegatingView.java:59)
at com.sap.tc.webdynpro.progmodel.controller.Controller.initController(Controller.java:227)
at com.sap.tc.webdynpro.progmodel.view.View.initController(View.java:741)
at com.sap.tc.webdynpro.progmodel.controller.Controller.init(Controller.java:206)
at com.sap.tc.webdynpro.progmodel.window.ViewManager.getView(ViewManager.java:668)
at com.sap.tc.webdynpro.progmodel.window.ViewManager.bind(ViewManager.java:539)
Read more...
Environment
Netweaver Application Server Java -7.5 SP35
Keywords
500 Internal Server Error,Failed to process request. Please contact your system administrator,Add Trusted Systems,update certificate,java.lang.IllegalAccessError,com.sap.engine.services.keystore.impl.security.CodeBasedSecurityConnector.domains , KBA , BC-JAS-SEC , Security, User Management , Problem
About this page
This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP for Me (Login required).Search for additional results
Visit SAP Support Portal's SAP Notes and KBA Search.
SAP Knowledge Base Article - Preview