SAP Knowledge Base Article - Preview

3795537 - Mail Sender Channel Reports Microsoft Graph Authentication Errors

Symptom

When the Mail adapter attempts to access a mailbox through the Microsoft Graph API, authentication errors such as the following are displayed in the default traces:

  • AADSTS50105 - The signed in user isn't assigned to a role for the application
  • AADSTS50057: The user account is disabled

The errors occur when SAP PO uses the configured Microsoft Graph API credentials, including the Tenant ID, Client ID, and Client Secret.


Read more...

Environment

  • SAP NetWeaver
  • SAP Process Integration

Product

SAP NetWeaver all versions ; SAP Process Integration all versions

Keywords

Mail adapter, Microsoft Graph API, SAP PO Mail adapter, AADSTS50057, AADSTS50105, Microsoft Entra ID, user account disabled, user not assigned to application role, Client Secret, Tenant ID, Client ID, Microsoft Graph authentication, Microsoft Graph API mailbox access, SAP Process Orchestration Mail adapter authentication error , KBA , BC-XI-CON-MAI , Mail Adapter , Problem

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP for Me (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.