Symptom
- Custom CDS view: YY1_XYZ_Cube
- Custom analytical Query: YY1_XYZ_QUERY
- InA service: YY1_XYZ_QUERY
- Application: YY1_123_AQFA
- When accessing the application directly: https://my123456.s4hana.cloud.sap/ui#AnalyticQuery-analyzeInMDA?query=YY1_XYZ_QUERY
- Error: Failed to start DataProvider program! Reason: Error [Server]: (#121) Authorization check failed. Please check start authorizations.; MsgClass: BW_BICS_INA;; OlapMsgClass: 0;
- Analytical query does not become available in enterprise SAC (communication scenario SAP_COM_0065) after following the steps in 2710858 - Custom Analytical Queries created in SAP S/4HANA Cloud Public Edition are not visible in SAP Analytics Cloud - SAP for Me
Environment
SAP S/4HANA Cloud Public Edition 2608
Reproducing the Issue
- Create and publish a custom CDS view (analytical cube) on top of a standard analytical data source; optionally add calculated fields.
- Create a custom analytical query on top of the custom cube using the “Custom analytical queries and services” app.
- Create the corresponding InA service for the custom analytical query.
- Create and publish an analytical application/report via “Manage KPIs and Reports” and assign it to a business catalog.
- Open the application MDA application.
- Error: Failed to start DataProvider program! Reason: Error [Server]: (#121) Authorization check failed. Please check start authorizations.; MsgClass: BW_BICS_INA;; OlapMsgClass: 0;
- Create and publish a custom CDS view (analytical cube) on top of a standard analytical data source; optionally add calculated fields.
- Create a custom analytical query on top of the custom cube using the “Custom analytical queries and services” app.
- Create the corresponding InA service for the custom analytical query.
- Create and publish an analytical application/report via “Manage KPIs and Reports” and assign it to a business catalog.
- Search the query in enterprise SAC (for example, via the SAC add-on).
- The query is not available.
Cause
- The IAM application (transaction-based app) generated during publish does not contain the required InA service and authorizations.
- Assigned roles do not include the necessary authorizations for the corresponding InA service of the custom analytical query.
Resolution
The solution of this issue is currently under investigation. Please follow this KBA for updates.
Workaround:
- Access Manage KPIs and Reports application.
- Under Multidimensional Reports tab, select the newly created app and click on Edit.
- No changes required, just click on Save and Publish.
See Also
Keywords
authorization check failed, #121, BW_BICS_INA, InA service, dataprovider error, custom analytical query, not visible in sac, manage kpis and reports, publish analytical app, role authorization, SIA6, query v3, multi-dimensional analysis, sac add-on, start authorizations , KBA , BC-SRV-APS-ANA-SSB , SAP Smart Business , Problem
Product
SAP S/4HANA Cloud Public Edition 2608
SAP Knowledge Base Article - Public