SAP Knowledge Base Article - Public

3798706 - Unable to Open SharePoint Files in Work Zone

Symptom

You have integrated SharePoint with SAP Work Zone (workspace).
When trying to access the files, it's returning with an error:

  • Not Found
  • Not Found: Impossible to find this resource

Environment

SAP SuccessFactors Work Zone

Reproducing the Issue

  1. Go to Work Zone.
  2. From the Workspace, access the SharePoint file/s.
  3. Observe that it will result to an error.

Cause

  1. External Folder in Workspace Admin Settings is not enabled
  2. Lack of Permissions
  3. Ensure that Azure AD Application is registered
  4. Validate the the SharePoint URL Configuration
  5. "Enable File Sharing" from 'Features' is disabled

Resolution

1. Ensure that External Folder in Workspace Admin Settings is enabled:
Enabling External Folders and Repositories | SAP Help Portal
3712389 - How to enable external repositories for the workspace in Build Work Zone, advanced edition - SAP for Me

  1. In the workspace, open the menu and choose Workspace Admin Settings.
  2. Choose Edit Workspace.
  3. On the SETUP tab page, choose Add external folder for the SharePoint application.
  4. Select the folders or repositories you want to use in the external content widgets.
  5. After enabling, use the page designer tool to add the external content widgets to your workspace.

2. Grant SharePoint permissions:
Access to SharePoint Repository | SAP Help Portal

  1. Confirm the user has been granted access to the relevant SharePoint folder or document library.
  2. Navigate to Library Settings > Permissions for this document library and use the Check Permissions option to validate access.
  3. If permissions are missing, grant the appropriate access level

>> Just an extra layer of confirmation with configuration.

3. Confirm the Azure App Registration:
3226185 - How to integrate SAP Work Zone with Microsoft Office 365 SharePoint - SAP for Me
Troubleshooting Documents | Workspace 365 Support Portal

  1. Confirm the registered Azure AD application has the correct Redirect URI (matching the underlying Jam service URL found in Admin Console > Overview in Work Zone).
  2. Ensure the required Microsoft Graph API permissions (e.g., Sites.FullControl.All or Sites.Selected) are assigned and consented.
  3. Verify the Client ID and Client Secret are valid and not expired.

4. Validate the the SharePoint URL Configuration:
Troubleshooting Documents | Workspace 365 Support Portal

  1. As an admin, navigate to Settings > Integrations > SharePoint documents and verify the root URL is in the format https://companyname.sharepoint.com (not companyname-my.sharepoint.com).
  2. If the document library name contains spaces, verify the path encoding is correct in the adapter or integration configuration.

Clear cache and retry, or test it in Private Browser.

If all these are tried and it's still not working.
5. Ensure that "Enable File Sharing" feature is enabled.

See Also

Features

Keywords

SharePoint, error, not found, resource, workspace, files, not accessible, unable to open files, azure ad , KBA , LOD-SF-SWZ-CNT , General Content (File Download & Upload) , How To

Product

SAP SuccessFactors Work Zone all versions