SAP Knowledge Base Article - Preview

3799154 - Jobs fail to start due to broken JDBC connections in IDM Java connection pool

Symptom

  • Custom jobs cannot be updated, modified, or started.
  • NetWeaver Administrator default trace shows that a pooled JDBC connection to the database is broken and marked as unrecoverable:
    • SQL error occurred on connection :null:dbo: code=0, state="<null>", message="The connection is broken and recovery is not possible. The connection is marked by the client driver as unrecoverable. No attempt was made to restore the connection.". [EXCEPTION] com.microsoft.sqlserver.jdbc.SQLServerException: The connection is broken and recovery is not possible. The connection is marked by the client driver as unrecoverable. No attempt was made to restore the connection.
  • Error observed during internal authorization/security check that queries the database prior to job start


Read more...

Environment

  • SAP Identity Management 8.0

Product

SAP NetWeaver all versions

Keywords

idm, custom job fails, job cannot start, jdbc connection broken, unrecoverable connection, connection pool, datasource, sql server, default trace, nwa, destroy connections, as java, idm java runtime, database restart, firewall idle timeout , KBA , BC-IAM-IDM , Identity Management , Problem

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP for Me (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.