SAP Knowledge Base Article - Preview

3800762 - SAP Data Services job or Designer repository login fails with ORA-29003: SSL transport detected mismatched server certificate during OCIServerAttach

Symptom

  • Data Services job fails with error immediately after start
  • OCI call <OCIServerAttach> for connection <...(SECURITY= (SSL_SERVER_CERT_DN = "cn=null")))> failed: <ORA-29003: SSL transport detected mismatched server certificate.>
  • The same error can occur when logging on to the Oracle repository from the Designer application


Read more...

Environment

  • SAP Data Services
  • Oracle

Product

SAP Data Services 2025

Keywords

ORA-29003, ssl_server_dn_match, mismatched server certificate, OCIServerAttach, ssl_server_cert_dn, cn=null, sqlnet.ora, Data Services, DS job fails, repository connection, Designer, Job Server, Oracle client , KBA , EIM-DS-EXE , Job Execution , Problem

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP for Me (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.