SAP Knowledge Base Article - Public

3800795 - IPS User Provisioning Job fails with 400 error when using sac.api.version 2 for SuccessFactors Platform Analytics

Symptom

  • Identity Provisioning (IPS) user sync from SuccessFactors to SAP Analytics Cloud (Stories in People Analytics) fails with a generic error message "400, Response: {"schemas":["urn:ietf:params:scim:api:messages:2.0:Error"],"status":"400","scimType":"invalidValue","detail":"Request is unparsable, syntactically incorrect, or violates schema."}"
  • The help guides for Enabling Story Reports | SAP Help Portal and Identity Provisioning were followed SAP Analytics Cloud | SAP Help Portal 

Environment

  • SuccessFactors Platform Analytics
  • User Provisioning

Reproducing the Issue

  1. Migrate SuccessFactors IPS source from OData to SCIM (sf.api.version = 2) and run Refresh Synthetic Group Data in SuccessFactors.
  2. Recreate or use existing SAC IPS target and run IPS read/write (or simulation) job from SuccessFactors to SAC.
  3. Observe that users are not created/updated in SAC and IPS logs contain HTTP 400/429/500 errors listed in Symptom.

Cause

  • SAC SCIM v2 (/api/v1/scim2) is not supported for SuccessFactors embedded SAC tenants; using sac.api.version = 2 leads to generic SCIM 400 errors.
  • This is a known issue as not embedded Analytics offerings of SAP Analytics Cloud do not implement the SCIM 2.0 specification in its entirety.
    Please refer to the remainder of this document for details on what is supported. 

Resolution

See Also

Keywords

ips, successfactors, sac, stories in people analytics, scim v2, scim v1, sac.api.version, sf.api.version, provisioning, invalidSyntax, invalidPath, invalidValue, http 429, http 500, csrf token path, groups attribute, roles mapping, honorificPrefix, update ias/ips job, refresh synthetic group data , KBA , LOD-ANA-LS , Licensing and Full User Equivalent , Problem

Product

SAP Analytics Cloud all versions