Symptom
- When running the datachange function, the command returns as expected
select datachange('table_name', null, null)
---------
0 - But the ASE errorlog reports a message with no error number
Failed to allocate memory for column level datachange counters for database 'db_name' (4), object 'table_name' (12345678), data partition 'table_name_12345678' (12345678).
Column level datachange counters will not be tracked. Increase the config parameter 'procedure cache size' to allocate more memory. - A select * on the table returns error 724 to the client and breaks the connection
select * from table_name
Msg 724, Level 20, State 3:
Internal Error: Function 'memallocheap' was passed an illegal size value (0).
ASE is terminating this process. - Error 724 is also reported in the ASE errorlog with a stack trace
Error: 724, Severity: 20, State: 3
Internal Error: Function 'memallocheap' was passed an illegal size value (0).
SQL Text: select * from table_name
-- stack functions
memallocheap
all_expand
expand_ALL_nodes
colnames
colnames_driver
Read more...
Environment
SAP Adaptive Server Enterprise (ASE)
Product
SAP Adaptive Server Enterprise all versions
Keywords
KBA , BC-SYB-ASE , Sybase ASE Database Platform (non Business Suite) , Problem
About this page
This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP for Me (Login required).Search for additional results
Visit SAP Support Portal's SAP Notes and KBA Search.
SAP Knowledge Base Article - Preview