Symptom
- Transaction RZ10 → Utilities → Import Profiles → Of Active Servers fails with: "ASCS profile Could not be read. The import is therefore not possible."
- Manual ASCS profile import in RZ10 (entering the ASCS profile name and clicking Import) also fails with the same error
- ICM starts with no HTTP or HTTPS service active:
HTTP: -, HTTPS: - dev_icmtrace shows the following SSL initialization errors at ICM startup:secussl_Create_SSL_CTX(): PSE "...\SAPSSLS.pse": missing SSO credentials, PSE is protected with PIN/password!SapISSLAddCredential(): Error SSSLERR_PSE_MISSING_PIN trying to create SERVER Credential for "...\SAPSSLS.pse"Initialization of SSL library failed -- NO SSL available!IcmServInitSSL: SapSSLInit (rc=-82): SSSLERR_PSE_MISSING_PIN
- Subsequently, when RZ10 attempts the ASCS profile read:
IcmIConnInitProtocolSpecificAttributes: No service for protocol HTTPS started
Read more...
Environment
- Product: SAP NetWeaver AS ABAP 7.50 and higher / SAP_BASIS 750+
- OS: Windows (confirmed; applies to Unix/Linux as well — see note in Solution)
- Kernel: 754 or higher (recent kernel with systemPKI active)
system/secure_communication = ONset in DEFAULT.PFL
Product
SAP NetWeaver 7.5 ; SAP NetWeaver Application Server for ABAP all versions
Keywords
ASCS profile could not be read, RZ10 import, SSSLERR_PSE_MISSING_PIN, SAPSSLS.pse, PSE PIN, seclogin, cred_v2, SAPServiceSID, ICM SSL initialization failed, NO SSL available, HTTPS not started, IcmServInitSSL, system/secure_communication, systemPKI, BC-CCM-CNF-PFL, profile import, sapgenpse, SECUDIR, Wrong or missing PIN for PSE, ICM no HTTPS , KBA , BC-CCM-CNF-PFL , Profile Maintenance , BC-CST , Client/Server Technology , BC-CST-STS , Startup Service , BC-SEC-SSL , Secure Sockets Layer Protocol , Problem
About this page
This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP for Me (Login required).Search for additional results
Visit SAP Support Portal's SAP Notes and KBA Search.
SAP Knowledge Base Article - Preview