SAP Knowledge Base Article - Preview

3801767 - Remote database connection to an on-premise system fails due to an error '-10709'

Symptom

  • When trying to make a remote data source connection from our HANA Cloud to an on premise database, it fails due to an error '-10709'.
      • SQL Error: Unable to connect remote source: [SAP AG][LIBODBCHDB SO][HDBODBC] Communication link failure;-10709 Connection failed (RTE:[89133] Proxy server connect: Network unreachable (x.x.x.x:<port> -> <remote host>:<port>)) (adapter type: hanaodbc, source name: <Remote Source Name>)
  • Verified the cloud connector connection and location ID, user name and password are correctly set up. 
  • Set the IP allowlist to all. 


Read more...

Environment

SAP HANA Cloud

Product

SAP HANA Cloud all versions

Keywords

SDA, HANA Cloud, remote, remote source, 10709, Network unreachable , KBA , HAN-CLS-HC , HANA Cloud Services HANA Cloud , Problem

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP for Me (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.