Symptom
- Error when scheduling a report to SFTP from report center: File path does not exist: /
- SFTP Host Addresses uses an Amazon AWS SFTP Server
Environment
SAP SuccessFactors HCM Core 2605
Reproducing the Issue
- Go to Report Center.
- Open a report (for example, select the three dots on a report) and choose New Schedule.
- In Destination, select SFTP.
- Enter SFTP host, port, username, password, file path and file name.
- Click Test Connection or run the schedule.
- Observe errors such as “File path does not exist: /
Cause
The error "File Path does not exist." indicates that the SFTP login account does not have the required access to the root directory (/) or the specified target directory on the SFTP server.
This issue is related to SFTP server permissions and must be addressed by the customer's IT or SFTP administrator. It is not caused by Canvas Reporting.
For Table and Story report deliveries, the SFTP account must have the necessary Write and Delete permissions on the destination directory. Without these permissions, report delivery may fail with the reported error.
Resolution
NOTE: This will only work in Table and Story report type.
Canvas Reporting DO NOT currently support scheduling reports using Amazon AWS SFTP Server endpoints.
See Also
- refer to: 2283199 – initial setup of SFTP on report distributor (canvas)
- refer to: 2089448 – data center details and outbound IP addresses
- refer to: 3058311 – unsupported character password error for SFTP
- refer to: 2580876 – FTP error login has no write permission (Report Center)
- refer to: 3084768 – SFTP connectivity considerations for report center
Keywords
report center, canvas, sftp, file path does not exist, no write permission, delete permission, root directory, integration center, story report, mac algorithm negotiation failed, aws transfer family, outbound ip, aws sftp , KBA , LOD-SF-ANA-EXP , Report Exports (Ad Hoc, YouCalc, ORD) , LOD-SF-ANA-RDT , Report Distributor (Advanced Reporting, ORD) , Problem
SAP Knowledge Base Article - Public