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[bookmark: ChecklistSummary]

[bookmark: _Provide_Login_info][bookmark: GeneralInfo][bookmark: _Toc225739327][bookmark: _Toc322902601][bookmark: LoginInfo]Detailed Instructions on How to Gather Diagnostics Summary: 
[bookmark: _Toc322902602]Provide Login info
· Provide the company instance and the username that you have enabled for us to replicate the issue.
· To enable support access go to Admin Tools > Grant Support Access > Find the username(s) and choose Unlimited or set a time.
· If this affect only certain end users, grant access to their account
· Please grant access to at least one administrator account that has full administrative rights
· [put answers above]
[bookmark: _Collect_server_information][bookmark: StepstoProduce][bookmark: _Toc322902603]Steps to reproduce the slowness
· Provide detailed steps to reproduce the issue with full screenshot.
· Please open a word doc; copy & paste into this word doc screenshots of the issue (full screen – not cropped) then attach your document to the case. 
· It is helpful for screenshots to contain:
- A brief explanation for each screenshot that clarifies what things you would like me to take note of.
- Shows the usernames involved and who I might need to proxy in as
- Steps leading up to the issue so I quickly understand how to replicate
- Comment on what might be missing if that is the issue
- When showing comparisons, explain what differences you are highlighting
- We ask that you not crop the screenshots, just leave full screen as there are many other elements on the page that we may want to take note of that help us in troubleshooting.
· If the performance issue cannot be reproduced from SuccessFactors side, or the sequence of actions to reproduce is complicate, please do a Gotomeeting web session, and record the reproducing steps.
· For full details on capturing screenshots, webmeetings and HttpWatch, please refer to the document “How to Capture Screenshots HttpWatch and GotoMeetings.docx”
[put answers above]

[bookmark: _Toc322902604]Collect server information and timestamp
· Ultra: When the customer login to Home Page of SuccessFactors application, they can obtain the server info by navigating to Help Icon. (Home PageHelp Icon  About SuccessFactors). Please refer to Figure 1.
[put answers above]
 [image: ]
[bookmark: _Toc322901117]Figure 1: Help Icon for Ultra
After clicking on the “About SuccessFactors” icon, customer can see a popup window. The server and timestamp information are shown in the Figure 2. Please take a screenshot and send the information to SuccessFactors.
[image: ]
[bookmark: _Toc322901118]Figure 2: About SuccessFactors Screen.
V10 Clients: You can find this information at the bottom of most pages as shown below. Please copy & paste the SuccessFactors application server information in the page footer at the bottom of the SuccessFactors screen. [image: ]
[bookmark: _Toc322902605][bookmark: _Gather_Browser_Settings]Browser and System setting information.
[bookmark: _Toc322902606]Gather Browser Settings
[bookmark: _Verify_your_browser][bookmark: _Toc322902607]Verify your browser is set to automatically check for newer version of webpage :

For IE 6 & 7. Tools > Internet Options > General > Temporary Internet Files (Browsing History) > Click Settings Button > Make sure "Check for newer version of stored pages" is set to "Automatically". 
[put answers above]

[image: ]
[bookmark: _Toc322901119]Figure 3: Internet Options for Temporary Internet Files for IE
[bookmark: _Toc322902608] For Firefox. Firefox has no equivalent to this setting. 
To reload a page at any time, click the Reload button in Firefox's Navigation Toolbar. Firefox then loads and displays the latest version of the page
[bookmark: _Check_the_amount][bookmark: _Toc322902609]Check the amount of disk space to use for Temporary Internet files folder. The value should be a minimum of 128MB:
For IE 6 & 7: Tools > Internet Options > General > Temporary Internet Files (Browsing History) > Click Settings Button > Check Disk Space to use
For Firefox: Tools > Options > Advanced > Network Tab > Check Cache setting
Please refer to Figure 12 for disk space usage.
[bookmark: _Check_HTTP_1.1][bookmark: _Toc322902610]Check HTTP 1.1 Support on browser(Yes/No): 

For IE 6 & 7. Tools > Internet Options > Advanced > make sure "Use HTTP 1.1" and "Use HTTP 1.1 through proxy connections" are checked.

[image: ]
[bookmark: _Toc322901120]Figure 4: HTTP 1.1 setting for IE
[bookmark: _Check_the_Security][bookmark: _Toc322902611] Check the Security setting on the browser: 
Navigate to ToolsInternet Options Advanced  Security section. Please refer to Figure 4 for details. Provide SuccessFactors information on whether the following two setting are checked. 
a. “Do not save encrypted page to the disk”.
b. “Empty Temporary Internet Files folder when browser is closed”.
If checked, please un-check these options.

[image: ]
[bookmark: _Toc322901121][bookmark: _Gather_System/desktop_Resources.]Figure 5: Checking encryption and empty cache setting for IE

[bookmark: _Run_the_network][bookmark: _Gather_System/desktop_Resources][bookmark: _Toc322902612]Gather System/Desktop Resources, Ping, Tracert, Network & Bandwidth Tests – Automated Tool
1. Extract the package (SF Performance Tool.zip) to your desktop. The tool can be provided by Customer Success or downloaded from the Performance Diagnostics solution: https://support.successfactors.com/3Knowledge_Base/SuccessFactors_BizX/Platform_Resources/What_to_do_if_the_SuccessFactors_Application_Seems_to_Run_Slow_(System_Diagnostics) 
2. Unzip the files to your desktop. This will create a folder “SF Performance Tool”
2.1 Open “SF Performance Tool > SF Performance Tool” folder
2.2 Double click Run.bat file
2.3 From Security Warning Dialoig Box confirm/click Run button and follow the instructions in the cmd window.
Feature Implemented:  
		  1. Collect IE browser setting
		  2. Collect system/desktop resources of current machine
		  3. Run the network bandwidth test to SuccessFactors server
		  4. Run tracert and ping to SuccessFactors server 
Results are written to a "perf_data_YY_MM_DD_TIME.html" file in Results folder. Attach the results files to your case.
Note: This should not take more than 5-7 minutes to complete. Please attach the html file from the Results folder to this case.


[bookmark: _Toc322902613][bookmark: OLE_LINK8][bookmark: OLE_LINK9]Run HttpWatch tool to collect performance data
[bookmark: _Toc253651779]NOTE: If SuccessFactors can replicate the issue on their end, then the SuccessFactors Support Staff should simply capture the httpWatch file so there is no need for the client to install on the client side. We do not require that clients install HttpWatch, and this is typically not required for all performance issues, however if we are unable to define the issue based on the information above, and the issue can only be replicated by the client, then it may become a requirement. The client will need to engage a person from IT that can do this.  Please download HttpWatch Basic Version from the following website. http://download.httpwatch.com/httpwatch.exe

For full details on installing and using HttpWatch please refer to the document “How to Capture Screenshots HttpWatch and GotoMeetings.docx”
[Add file to your case]

[bookmark: _Recording_GoToMeeting_session.][bookmark: _Toc322902614]Recording GoToMeeting session.

Recorded webmeetings are very helpful when you want to demonstrate in real time thetime-elapsed showing slowness. Webmeetings are not the best tool to simply capture step-by-step instructions, as they produce very large files hard to work with, cannot be searched or easily navigated, and often end up capturing other navigation of the user not helpful to the case and may actually be misleading, so please use simple screenshots to document replication steps, and then augment that with recorded sessions when only via a recording can some aspect of the issue be clearly demonstrated.

For full details on installing and recording webmeetings please refer to the document “How to Capture Screenshots HttpWatch and GotoMeetings.docx”
[Add file to your case]
[bookmark: _Toc322902615]Gather System/Desktop Resources – Non Automated Method

Note: This manual option only needs to be performed in the event that the automated option is not possible or fails to run successfully. 
In Windows go to “Start” button. On the Run box enter: msinfo32. Please choose File > Export and save the system settings to your desktop and then attach the file to your case. Provide also provide the following basic info from the msinfo32 screen in your general ansers.
· OS Name
· Version
· Processor information
· Total physical memory
[put answers above]
[bookmark: _Run_the_network_2][bookmark: _Toc322902616]Run the network bandwidth test to SuccessFactors server
Note: This manual option only needs to be performed in the event that the automated option is not possible or fails to run successfully. 
SuccessFactors hosts customer data in three datacenters. They are Arizona (AZ), New Jersey (NJ) and Europe (EU) datacenters. Please execute a network bandwidth test by visiting one of the three links mentioned below. The links are
· If you login to performancemanager.successfactors.com, then use 
NJ: https://performancemanager8.successfactors.com/diagnostic/main
· If you login to performancemanager4.successfactors.com, then use 
AZ: https://performancemanager4.successfactors.com/diagnostic/main
· If you login to performancemanager.successfactors.eu, then use 
EU: https://performancemanager.successfactors.eu/diagnostic/main
[bookmark: _GoBack]Click the “Run Test” button next to the “Bandwidth Test: untested”.
[image: ]
Once the test shows ‘Bandwidth Test’ results in green, you are ready to capture your screenshots. Please run the above test couple of times during the day and provide the above collected bandwidth range information to SuccessFactors.
[put answers above]

[bookmark: _Toc322902617]Ping and Tracert
Note: This manual option only needs to be performed in the event that the automated option is not possible or fails to run successfully. 
Open a command window (Start > run > cmd)
Use Ping command and ping successfactors.com
Use tracert command and ping successfactors.com
Provide results in screenshots
[bookmark: _Run_the_network_1][bookmark: _Toc322902618]Run the network bandwidth test to third party server
Note: This manual option only needs to be performed in the event that the automated option is not possible or fails to run successfully. 
Please run the network bandwidth test by visiting 
http://www.pcpitstop.com/internet/bw.asp . Pick a server and provide SuccessFactors download and upload speeds. Please refer to Figure 6 and 7 for details.
[put answers above]

[image: ]
[bookmark: _Toc322901122][bookmark: _/][bookmark: _Toc254194071][bookmark: step_2][bookmark: OLE_LINK3]Figure 6: PC Pitstop: Pick a server
[image: ]
[bookmark: _Toc322901123]Figure 7: PC Pitstop showing upload and download speed.
[bookmark: _Run_Browserscope_Network][bookmark: _Toc322902619][bookmark: OLE_LINK26][bookmark: OLE_LINK27]Run Browserscope Network Test
[bookmark: OLE_LINK39][bookmark: OLE_LINK40]Note: This manual option only needs to be performed in the event that the automated option is not possible or fails to run successfully. 
[bookmark: OLE_LINK64][bookmark: OLE_LINK65][bookmark: OLE_LINK43][bookmark: OLE_LINK44][bookmark: OLE_LINK41][bookmark: OLE_LINK42]Navigate to http://www.browserscope.org. Click on “Network” Tab. Then, click on “Run the Network Tests” button. Capture the test results and save it to this document. Figure 8 shows a sample test result.
[put answers above]
 
[image: ]
[bookmark: _Toc322901124]Figure 8: Sample Network Test Results from Browserscrope.org.
[bookmark: step_5][bookmark: _Run_HttpWatch_tool]
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[bookmark: step_1][bookmark: OLE_LINK37][bookmark: OLE_LINK38]
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