SAP Knowledge Base Article - Public

2316953 - Troubleshooting Course/Content Not Marked Completed in SAP SuccessFactors Learning

Symptom

  • Users completed the course but it is still in their learning plan
  • The course displays a certificate informing the users they have completed the course but the same is not reflecting in the user's learning history/plan
  • The course is not being marked "Completed" even though it was completed successfully

Environment

SAP SuccessFactors Learning

Reproducing the Issue

  1. Complete an iContent course in Learning >
  2. The course continues to display in Learning Plan >
  3. The course is not marked as completed as expected.

Cause

This can be caused by the following (see resolutions/troubleshooting steps below for each cause):

  1. The content is not sending the completion statuses properly 
  2. User closes/navigates away from the application 
  3. The settings are incorrect at the Item Level 
  4. Users are not meeting the "completion" requirements as configured 
  5. In an integrated environment, the session maintenance settings are incorrect 
  6. There is a required survey that has not been completed 
  7. Network/Environmental issues 
  8. System Time Out (30min).

Resolution

When an Item is not marking the Item/course completed is because of the following reasons:

  1. The content is not sending the completion statues properly
    • For example, the content object should send the status as "Passed"(P) or "Completed"(C) which depends on the type of contents, such as AICC or SCORM (SCORM 2004 and SCORM1.2/AICC)
      • To trace the information that is sent by the content, please see 2978324
      • To check the data sent from the content to the LMS at the database level, please refer to the below section "How to Troubleshoot Content Completion Issue"
    • If it sends some other improper text as the status, Learning will not recognize it and will not mark it complete
    • If this is the case, most users will have issues with the course.
      • Depending on how the content is coded, the way the users navigates through the content (click-stream) could have an impact on how/when the content sends data.
      • An example of content being coded differently and some users receiving completion versus others, is a built-in "exit" button. If a user closes out of the content via the browser "X" window button and does not use the "exit" button, the content might not send the proper completion status.
    • Be sure the content is configured to send the expected completion status to Learning for the correct status to be set. SAP Support does not provide assistance with content troubleshooting, please get with your content vendor.
    • For Scorm content, Please also ensure commit() function is being called by content after the completion status and score are sent properly. Commit() function submits the values to LMS that are sent by content using LMSSetValue() 2978324
  2. User closes/navigates away from the application
    • The way that content communicates with the Learning application is through an API (SCORM or AICC). If the user navigates away from the application (parent) window but continues in the content window (child) towards completion, the API communication has been interrupted. The child window cannot send completion information due to the parent window that keeps the API communication ongoing, has been disrupted.
  3. The settings are incorrect at the Item Level
    • If this is the case, most users will face this issue
      • The exception for this case is if the Item has a Mastery Score set
      • An example of this being an issue is if the Mastery Score is set to 80 but the content is coded to send and inform the user that they got a completion with a score of 70 or above. If the user passed with a score of 75 and the content sends a completion, Learning will reject the completion and the Item will stay in the Learning Plan
      • If Mastery Score is an issue, update the Mastery Score and reassign the Item
    • Search and open an item at Learning Administration -> Learning Activities -> Items -> Search and open/click on an item -> access "Online Content" tab
    • Under Settings -> Completion tab, select the appropriate settings:
      • If the Item has one content object that must be complete to receive completion, select either "Add to History on Completion of All Content" or "Add to History on Pass"
      • If the Item has multiple content objects that must be completed to receive completion, select "Add to History on Completion of All Content"
      • If the Item has multiple content objects and only one must be completed to receive completion, select "Add to History on Pass"
    • If the proper settings are not checked, make sure set them and reassign the Item.
  4. Users are not meeting the "completion" requirements as configured. For example: 
    • There are content objects that send the status only when the user clicks a button, such as "Exit" or "Close" or "X" or "Submit" etc., on the last slide/page
    • Some content sends the status when the content/browser window is closed
    • Some content sends the status the moment it is launched (Under Settings -> Completion tab -> if the setting "Complete Content on Launch" is checked)
    • If this is the case, users who do not complete the courses properly will not receive credit for it
    • To correct, observe the steps the user is taking to complete the course and determine which steps may be missed to meet the course's configured requirements for completion
  5. In an integrated environment, the session maintenance settings are incorrect
    1. Under Learning Administration -> System Administration -> Configuration -> System Configuration -> LMS_ADMIN:
      • "contentStructurePageExpireDuration" should be 120.
      • "contentStructurePageKeepAliveInterval" should be 300. Do not modify these values.
    2. Under Learning Administration -> System Administration -> Configuration -> System Configuration -> AUTHENTICATION:
      • httpSessionTimeout should be 1800 (30 minutes). Do not modify this value.
  6. If the item has a required survey associated to it, have the user complete the survey or remove the survey from the user. If still does not work, create a new Item.
  7. There are times that are external factors, which outside the control of SAP, impact content completion information such as:
    • Network
    • Browser Settings (check the "See Also" section)
    • VPN
  8. The User's completed status is not recorded in the system if the completion of the online content happened after the login session timed out/expired.
    • In this case, there is no workaround for this, as it is considered to be expected behavior in Learning, the user has to complete the course/item/curricula/survey when he is actually logged in the system.

How to Troubleshoot Content Completion Issue:

As described above, the best option to check content completion is by capturing the logs and running queries via PRD (if the issue can be replicated in the stage or sandbox instance where PRD is enabled. In case the issue is happening on Production, export a custom report from PRD and upload this in Production to get the results).

    • select STUD_CPNT_ID from PA_CBT_STUD_CPNT where STUD_ID='XXXX' and CPNT_ID='XXXX'; This table (PA_CBT_STUD_CPNT) contains the item details of the user where STUD_ID is the user ID and CPNT_ID is the item ID. This query will give a unique ID called STUD_CPNT_ID.
    • select AICC_DATA from PA_CBT_STUD_CPNT_MOD where STUD_CPNT_ID='XXXX'; Pass the STUD_CPNT_ID field that you got from the query above which will give the AICC_DATA where the time and completion details that are sent from the course will be stored.

  • If the value found is null, then there was no communication from the content to the LMS.
  • If the value found is: 
    • [PLATEAU CONTROL]
      FIRSTTIME=0
      WAS_SUSPENDED=0
      [CORE]
      TIME=
      SCORE=100,100
      LESSON_LOCATION=s07_t02
      LESSON_STATUS=PASSED

    • The TIME value was not sent by the content (it is the content's responsibility to do so and not LMS)
    • SCORE is 100 out of 100 (100 doesn't mean the user completed it as the system validates the status as well)
    • LESSON_LOCATION is useful when courses have bookmarking option i.e. resume functionality (it is the content's responsibility and not LMS), this stores the last location from which the LMS should resume the course for when the user launches the course again.
    • LESSON_STATUS stores the completion status sent from the content to the LMS. 

To illustrate this, lets assume that the Completion Status the content sends is P for Passed and F for Failed. The column Score is the score sent from the content.

LESSON_STATUS SCORE Mastery Score (Configured under the online content settings at the item level) LMS Completion
F 100 In this case, it it not relevant if the mastery score is enabled (with any value) or not. Even though the maximum score was achieved, the lesson_status sent was F (Failed). Failed or Incomplete
P 50

Considering the below situations:

1. No Mastery Score configured
2. Mastery Score configured to 60
3. Mastery Score configured to 50

The following results would be observed:

1. The course would be completed
2. Failed or Incomplete. Even though the status is P, the score is less than the value configured in the Mastery Score
3. Failed or Incomplete. Even though the status is P, the score should be higher than the value configured in the Mastery Score.

P Empty/Null

Considering the below situations:

1. No Mastery Score configured
2. Mastery Score configured to 60

The following results would be observed:

1. The course would be completed
2. Failed or Incomplete. If there is a Mastery Score configured at the item level in LMS, the content should send the SCORE data along with the LESSON_STATUS

Empty/Null 100 or Empty/Null In this case, it is also not relevant if the mastery score is enabled (with any value) or not. Null/Empty (Incomplete). The lesson_status is essential, the content must send it to the LMS, otherwise, the course will not be completed.

See Also

  • KB article 2473031 - Item does not move to Learning History after user completion
  • KB article 2456141 - SCORM Content completion status are not getting accepted by LMS causing completion issues in LMS
  • KB article 2310570 - Internet Explorer settings to launch online content - LMS
  • KB article 2251443 - Score is not Captured in Learning History
  • KB article 2185696 - Failed to Authenticate SAML Response - LMS from BizX - Safari Browser

Keywords

lms, course, incomplete, troubleshoot, content, completion, contentStructurePageExpireDuration, httpSessionTimeout, contentStructurePageKeepAliveInterval, Add to History on Completion of All Content, Complete Content on Launch, Add to History on Pass, login, expirated, time, out, timeout , KBA , LOD-SF-LMS-CNT , Content , LOD-SF-LMS , Learning Management System , LOD-SF-LMS-ITE , Items , Problem

Product

SAP SuccessFactors Learning all versions