Symptom
- To-do Panel showing HTTP 404 error for TodoEntryV2. Example: "/odata/v2/restricted/TodoEntryV2/TodoEntryV2";
- Picklist Center not loading any data;
- Status gave 404 error for To-do tile;
Environment
SAP SuccessFactors HCM Suite
Reproducing the Issue
- Login to any impacted instance
- Click on the To Do icon in header to open To Do Panel. 404 error will be shown
- Go to Picklist Center. No picklist data will be shown.
Cause
Caused due to OData API metadata cache.
Resolution
Perform Odata API metadata Refresh to resolve the issue
Follow below steps to refresh metadata:
- Go to Admin Center;
- At the Search Tools, search for OData API Metadata Refresh and Export
- When clicking Refresh, notice the message “Refresh Successful!” after metadata gets refreshed.
See Also
Keywords
To Do, To-do side panel, to-do not working, error with To Do, error 404, To Do Tasks, To Do tasks not showing, Picklist Center, Centre. , KBA , LOD-SF-PLT-TOD , To-Do List Issues , LOD-SF-PLT-PCK , Picklist Management Issue , Problem
Product
SAP SuccessFactors HXM Core 2305