SAP Knowledge Base Article - Public

3441939 - Users cannot be Searched via their Alternate Names

Symptom

  • Users cannot be searched via their alternate names. 
  • Manual re-indexing is always needed to make the users searchable by their alternate names. 

Environment

SAP Successfactors HCM Suite 

Reproducing the Issue

  1. Login to instance. Search for an alternate name of a sample user and no results would prompt. 
  2. Try to run the re-index via Provisioning
  3. Search for the alternate name again and the user with this alternate name will show on results.
  4. Add a new alternate name for another user and no results would prompt again. 

Cause

Alternate names are not included in HRIS Sync mappings which is why adding an alternate name does not trigger an HRIS Sync and re-indexing. 

Resolution

Add all alternate name fields to HRIS Sync Mappings.  Here is a helpful guide: Adding Sync Mappings in the HRIS Sync Mappings Section

See Also

Keywords

alt names, alt name, first-name-alt1, middle-name-alt1, last-name-alt1, Alternate Name, Alternative Name, Alternate Names, Alternative Name, labels, translations, re-index, search, people search, LOD-SF-PLT-SRH
 
, KBA , LOD-SF-EC-HRS , HRIS Sync , Problem

Product

SAP SuccessFactors Recruiting 2311