SAP Knowledge Base Article - Public

3478014 - Issues with Analytics Hub license - SAP Analytics Cloud

Symptom

A License has been assigned on a user, and now that License cannot be removed, one of the following errors can appear.

  • "User changes cannot be saved. The maximum number of Analytics Hub licenses have been reached. Please check your current license usage limits. Then deactivate users, delete inactive users, or consider an upgrade to your plan.
    Correlation ID: XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXX"
  • "There are no Analytics Hub licenses purchased.
    Correlation ID: XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXX"
  • "Team membership cannot be updated. The maximum number of Analytics Hub licenses have been reached. Please check your current license usage limits. Then deactivate users, delete inactive users, or consider an upgrade to your plan.

    Correlation ID: XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXX"

Issue context: After migrating from NEO to Cloud Foundry there are no more Analytics Hub Licenses available and a Role with the License remains on users.

Possible workflows affected where this error can be experienced:

  • Creating a new user
  • Deleting a user
  • Adding members to a team
  • Removing members from a team
  • Adding a Role to a user
  • Removing a Role from a user

Environment

SAP Analytics Cloud version: 2024.8.10

Reproducing the Issue

  1. Open SAP Analytics Cloud Tenant.
  2. Go to Security > Users.
  3. The error appears:
    1. "There are no Analytics Hub licenses purchased.
      Correlation ID: [...]" 
  4. From the same page, select a user with the incorrect assigned Analytics Hub License and change the roles on "Select User Roles".
  5. Try to select any Role or to clear the Selection > Click "OK" > and now "Save".
  6. The error appears and the previous Role and License return:
    1. "User changes cannot be saved. The maximum number of Analytics Hub licenses have been reached. Please check your current license usage limits. Then deactivate users, delete inactive users, or consider an upgrade to your plan.
      Correlation ID: [...]"
    2. "There are no Analytics Hub licenses purchased.
      Correlation ID: [...]"

Cause

This was identified as a bug.

Analytics Hub Licenses may have been purchased in the past, and after this license type has been removed from the SAC tenant any users who previously had an Analytics Hub Role may experience issues being added to teams or roles.
A Team can also have been previously mapped to a Analytics Hub Role, after Analytics Hub Licenses are removed there are problem adding/removing members to that team.

Resolution

If you are facing something similar, raise a case under "LOD-ANA-LS" and share this KBA.

See Also

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Keywords

SAP Cloud for Planning, sc4p, c4p, cforp, cloudforplanning, EPM-ODS, Cloud for Analytics, Cloud4Analytics, CloudforAnalytics, Cloud 4 Planning, BOC, SAPBusinessObjectsCloud, BusinessObjectsCloud, BOBJcloud, BOCloud., SAC, SAP AC, Cloud-Analytics, CloudAnalytics, SAPCloudAnalytics, kba, note, help, knowledge, chart, story, canvas, responsive, model, modeling, connection, tenant, version, linceses, license, hub, analyticshub, assign, assigned, can't, cannot, remove, removed, roles, team, teams, role, group, member, selection, select, save, change, migration, cf, neo, cloudfoundry, cloud foundry , KBA , LOD-ANA-LS , Licensing and Full User Equivalent , Problem

Product

SAP Analytics Cloud all versions