Symptom
A License has been assigned on a user, and now that License cannot be removed, two errors can appear.
- "User changes cannot be saved. The maximum number of Analytics Hub licenses have been reached. Please check your current license usage limits. Then deactivate users, delete inactive users, or consider an upgrade to your plan.
Correlation ID: XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXX" - "There are no Analytics Hub licenses purchased.
Correlation ID: XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXX"
Issue context: After migrating from NEO to Cloud Foundry there are no more Analytics Hub Licenses available and a Role with the License remains on users.
Environment
SAP Analytics Cloud version: 2024.8.10
Reproducing the Issue
- Open SAP Analytics Cloud Tenant.
- Go to Security > Users.
- The error appears:
- "There are no Analytics Hub licenses purchased.
Correlation ID: [...]"
- "There are no Analytics Hub licenses purchased.
- From the same page, select a user with the incorrect assigned Analytics Hub License and change the roles on "Select User Roles".
- Try to select any Role or to clear the Selection > Click "OK" > and now "Save".
- The error appears and the previous Role and License return:
- "User changes cannot be saved. The maximum number of Analytics Hub licenses have been reached. Please check your current license usage limits. Then deactivate users, delete inactive users, or consider an upgrade to your plan.
Correlation ID: [...]" - "There are no Analytics Hub licenses purchased.
Correlation ID: [...]"
- "User changes cannot be saved. The maximum number of Analytics Hub licenses have been reached. Please check your current license usage limits. Then deactivate users, delete inactive users, or consider an upgrade to your plan.
Cause
This was identified as a bug.
Resolution
If you are facing something similar, raise a case under "LOD-ANA-LS" and share this KBA.
See Also
- 2569847 - Where can you find SAC user assistance (help) to use, configure, and operate it more effectively?
- 2728183 - SAP Analytics Cloud (SAC) releases and release information
- 2511489 - Troubleshooting performance issues in SAP Analytics Cloud.
- Have a question? Ask it here and let our amazing SAP community help! Or reply and share your knowledge!
- 2487011 - What information do I need to provide when opening an incident for SAP Analytics Cloud?
- Search for SAP Analytics Cloud content using Google or Bing:
- https://www.google.ca/search?q=site%3Ahttps%3A%2F%2Fapps.support.sap.com+SAP+Analytics+Cloud
- https://www.bing.com/search?q=site%3Ahttps%3A%2F%2Fapps.support.sap.com+SAP+Analytics+Cloud
- Note: Add relevant text or warning/error messages to the text search field to filter results.
- SAP Analytics Cloud Connection Guide
- Getting Started with SAP Analytics Cloud Expert Community page
- SAP Analytics Cloud Get More Help and SAP Support
- Need More Help? Contact Support or visit the solution finder today!
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Keywords
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