Symptom
- Error : 'Rank could not be completed because the specified account/measure or version member is no longer available. Please update your rank selection' when ranking chart in SAP Analytics Cloud (SAC)
- When using a planning model, Top 5 rank is not working because Dimension member specified in Measure Coordinate can't be found in Dimension 'Version'.
Environment
SAP ANALYTICS CLOUD 2024.15.16
Reproducing the Issue
- Login to the SAC
- Open the story
- Apply the Top 5 rank filter on the chart
- In the version filter, uncheck the first filter.
Notice the error: "Rank could not be completed because the specified account/measure or version member is no longer available. Please update your rank selection."
Cause
- Behavior by design.
- When you use the Top 5 option, it will select the default version. This is typically the one with the lowest Version ID in the list of all 'active' versions in the Chart.
- In the Top 5 version, we use the 'first' version.
Resolution
If you wish to select a different version, it can only be set explicitly. This can be done by creating the rank via the Top N Options menu.
See Also
- 2487011 - What information do I need to provide when opening a case for SAP Analytics Cloud?
- Get More Help and SAP Support | SAP Help Portal
- 2569847 - Where can you find user assistance (help) for SAP Analytics Cloud to use, configure and operate it more effectively?
- SAP Analytics Cloud Connection Guide
- Getting Started with SAP Analytics Cloud Expert Community page
- SAP Analytics Cloud Get More Help and SAP Support
- Need More Help? Contact Support or visit the solution finder today!
Keywords
SAP Analytics Cloud, Rank, TOP N, TOP 5 , KBA , LOD-ANA-DES , Story Design & Visualizations , Problem
Product
SAP Analytics Cloud 1.0