Symptom
- All permissions were granted to the BPE Service User, but still, the BPE Error Tasks in To-Do panel is still not available.
- The BPE Error Tasks is missing even when tasks are available in BPE: Manage User Tasks
Environment
SAP SuccessFactors Onboarding
Cause
- The business process tile was set as invisible on the legacy home page.
- If a customer has previously hidden tiles in the Show/Hide To-Do Tiles on the legacy home page admin, those tiles remain hidden.
Resolution
As the legacy home page is deleted and no longer available, we need to run a script to remove the legacy data to address this issue. Once done, all hidden tiles will become visible in the to-do panel.
Ensure that the following pre-requisites are checked before logging a Support Ticket to run a script:
- Enable the switch "Enable BPE in UI" in Provisioning
- "Enable Business Process Engine" options in Provisioning.
- to the BPE Service User or to the RBP Role assigned to see the BPE Error tasks in To-do:
- Permission Category:
- Permissions Granted:
- Deploy Process Definition
- Process Management
- User Task Management
- Download Process Definition
- OData API Access for Business Process Engine
For Live Customers and Implementation Partners:
- Once the above requirements are checked, please log a support ticket
- Share this KBA as reference in issue description
- Provide your approval for the script execution.
For Cloud Technical Support
- See the internal memo of the KBA
See Also
Keywords
BPE Error Tasks, BPE, To-do, To-Do Panel, Error, Homepage, BPE Error, OBX, Onboarding, ONB2, ONB , KBA , LOD-SF-OBX-BPE , BPE Process Flow , Problem
Product
SAP SuccessFactors Onboarding all versions