SAP Knowledge Base Article - Public

3559450 - The Business Process Tasks in To-Do is not available even with all permissions granted - Onboarding

Symptom

  • All permissions were granted to the BPE Service User, but still, the BPE Error Tasks in To-Do panel is still not available.
  • The BPE Error Tasks is missing even when tasks are available in BPE: Manage User Tasks

Environment

SAP SuccessFactors Onboarding

Cause

  • The business process tile was set as invisible on the legacy home page.
  • If a customer has previously hidden tiles in the Show/Hide To-Do Tiles on the legacy home page admin, those tiles remain hidden. 

Resolution

As the legacy home page is deleted and no longer available, we need to run a script to remove the legacy data to address this issue. Once done, all hidden tiles will become visible in the to-do panel.

Ensure that the following pre-requisites are checked before logging a Support Ticket to run a script:

  • Enable the switch "Enable BPE in UI" in Provisioning 
  • "Enable Business Process Engine" options in Provisioning. 
  • To the BPE Service User or to the RBP Role assigned to see the BPE Error tasks in To-do:
    • Permission Category:
    • Permissions Granted:
      • Deploy Process Definition
      • Process Management
      • User Task Management
      • Download Process Definition
      • OData API Access for Business Process Engine

For Live Customers and Implementation Partners:

  • Once the above requirements are checked, please follow the steps mentioned below:

Troubleshooting Steps for Missing To-Do Panel Items:

To resolve issues with missing items in the To-Do panel, please have the customer perform the following checks:

  1. Enable To-Do Panel: Verify that the To-Do panel is enabled as per the instructions in the SAP Help Portal guide: https://help.sap.com/docs/successfactors-platform/managing-sap-successfactors-user-experience/enabling-to-do-panel

  2. Check Tool for Legacy Visibility Settings: Utilize the Check Tool to ensure the issue is not related to previously configured visibility settings for To-Do tiles on the legacy home page. Refer KBA: 3386260 - Category 41 To-Do Tasks are Not Visible on the To-Do Panel, Resolution section for Check Tool Execution. This action will remove the show/hide configuration in legacy homepage so all supported tiles (to-do categories) will be visible on the to-do panel

Next Steps if Issue Persists:

If the To-Do panel is enabled and no legacy visibility settings are identified as the cause via the Check Tool, the issue is not related to previous legacy home page configurations. In this scenario, we recommend the customer:

  • Review the configurations specific to the impacted To-Do items. The owner of each To-Do item is detailed in the following SAP Help Portal guide: Where To-Do Tasks Appear | SAP Help Portal 
  • If the issue continues after reviewing the configurations, please raise a support case with the component LOD-SF-OBX-BPE.

See Also

Keywords

BPE Error Tasks, BPE, To-do, To-Do Panel, Error, Homepage, BPE Error, OBX, Onboarding, ONB2, ONB , KBA , LOD-SF-OBX-BPE , BPE Process Flow , Problem

Product

SAP SuccessFactors Onboarding all versions