Symptom
Business Messages named as Appointment are stuck in "Long Running" status.
Environment
SAP Business ByDesign.
Reproducing the Issue
- Navigate to the Master Data Replication or Application and User Management view.
- Select Business Communication Monitoring and Show Business Messages with Errors.
- Observe Messages with Long Running status.
Cause
The issue arises due to the missing sync between the Outlook Add-in and the SAP Business ByDesign via the Outlook Groupware Plugin. Where the user has not logged into the Outlook Groupware Plugin for a significant period, leading to delayed/long running business messages.
Resolution
To fix these stuck Business Messages you can proceed with one of the following actions:
- Ask the user to perform the sync in the Outlook Add-in with SAP Business ByDesign.
- Or these messages can be cancelled.
To avoid this issue in future, inform the respective user to log in to the Outlook Groupware Plugin more often so that the message sent from SAP Business BYDesign would get synchronized to the Outlook successfully.
See Also
Keywords
Long Running, Messages, Delayed, Business Messages, ByD, Master Data Replication, Outlook Groupware Plugin, Sync, Integration, Outlook, ByD. , KBA , AP-RC-CEC-B2B , ByD On-Demand Cloud-Process Integration B2B , Problem
SAP Knowledge Base Article - Public