SAP Knowledge Base Article - Public

3590796 - Generic Issues with To Do's visibility in the To Do Panel

Symptom

  • Users not able to see specific To-Do tasks in the To-Do Panel from the right side on the Home Page (For Ex: A task added on the Category 41 To-Do Tasks via OData API)
  • Despite granting all necessary permissions to the BPE Service User, the BPE Error Tasks are still not appearing in the To-Do panel for onboarding users.

Environment

SAP SuccessFactors HCM suite

Reproducing the Issue

  1. Login to your SF instance. 
  2. Check the To-Do Panel from the right side on the Home Page
  3. Notice that the added Category for To-Do task is not being displayed.

Cause

If a customer has previously hidden tiles in the Show/Hide To-Do Tiles on the legacy home page admin, those tiles remain hidden in the latest home page.

Resolution

Troubleshooting Steps for Missing To-Do Panel Items:

To resolve issues with missing items in the To-Do panel, please have the customer perform the following checks:

  1. Enable To-Do Panel: Verify that the To-Do panel is enabled as per the instructions in the SAP Hel Portal - Enabling the To-Do Panel

  2. Check Tool for Legacy Visibility Settings: Utilize the Check Tool to ensure the issue is not related to previously configured visibility settings for To-Do tiles on the legacy home page. Refer KBA: 3386260 - Category 41 To-Do Tasks are Not Visible on the To-Do Panel > Under Resolution section - for Check Tool Execution. This action will remove the show/hide configuration in legacy homepage so all supported cards (todo categories) will be visible on the to-do panel

 

Next Steps if Issue Persists:

If the To-Do panel is enabled and no legacy visibility settings are identified as the cause via the Check Tool, the issue is not related to previous legacy home page configurations. In this scenario, we recommend the customer:

  • Review the configurations specific to the impacted To-Do items. The owner of each To-Do item is detailed in the following SAP Help Portal - Where To-Do Tasks Appear.
  • If the issue continues after reviewing the configurations, raise a support case with the appropriate module team (Identified in the above guide).

To‑Do Panel Hidden When Latest Shell Bar Experience Is Enabled

If the latest experience for the SAP shell bar is enabled, the To‑Do panel/icon will not appear in the header as documented in Changes Included in the SAP User Experience Updates | SAP Help Portal

This is because the To‑Do panel is being deprecated as it no longer aligns with SAP’s latest user experience standards.

See Deprecation of To-Do Panel | SAP Help Portal for more details on the deprecation. 

How to Check Whether the Latest Shell Bar Experience Is Enabled

  1. Go to Company System and Logo Settings.
  2. Search for Enable the latest SAP shell bar. 
    • If this is checked, the To-Do Panel will NOT be displayed on the header / shell bar. 
    • If this is unchecked, the To-Do Panel will be displayed. 

See Also

Keywords

To Do tasks visibility, To Do Items not showing in To DO Panel, LegacyTodoTileVisibility, to-do visibility, check tool type migration, BPE Error Tasks, BPE To Do  , KBA , LOD-SF-PLT-TOD , To-Do List Issues , Problem

Product

SAP SuccessFactors HCM Suite all versions