SAP Knowledge Base Article - Public

3712540 - Onboarding Processes Not Archiving

Symptom

  • Onboarding processes are not being archived as expected.

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  1. Attempt to archive onboarding processes via the Close Onboarding Processes Job.
  2. Observe that processes are not being archived.

Cause

The issue is occurring because one of the candidates is an external candidate and should be cancelled, and are unable to cancel.

Please create a support ticket to identify the affected candidate and retrieve the backend logs in order to determine the relevant error.

Example Error: 

  • Failed to upsert data for entity :EmpEmploymentTerminationresult : 
  • custom-stringX is a required field and cannot be blank.,
  • custom-stringY is a required field and cannot be blank.,
  • custom-stringZ is a required field and cannot be blank.
  • Failed record info: {EmpEmploymentTermination/okToRehire=true, EmpEmploymentTermination/eventReason=NO_SHOW_EVENT_REPORT, EmpEmploymentTermination/endDate=2023-10-05T00:00:00.000Z, EmpEmploymentTermination/personIdExternal=0100799, EmpEmploymentTermination/userId=1234}.
  • An exception occurred while updating the external event reason for termination for user ABCDEF.
  • userId XXX is an external candidate, and is unable to cancel this onboardee 

Resolution

To resolve this issue, we kindly request you to:

  1. Update the configuration by setting the mandatory fields[custom-stringX, custom-stringY, custom-stringZ] to No in Manage Business Configuration.

  2. Once this is done, please cancel the specific onboardee.

  3. After cancellation, kindly try archive again by running the job. It should work as expected.

However, if you prefer not to change the mandatory setting of the fields, there is an alternative workaround available.

As a workaround, we can configure a onSave rule on Employment Info. However, it restricts cancellation to be performed only after completion of new hire data review.

Please find the below steps to set up the rule.

Configuration for Workarounds/Solution:

Step 1: Set up business rule on Employee Information model from “Manage Business Configuration" UI
Select “Employee Information Model” entity, Rule Type = OnSave 

Step 2: Create rule:

Please make sure you choose “If condition” and “Set values” as per your business need.
Sample rule from test instance. In this example, we are setting up data for 3 mandatory fields – 1st one Custom field, Payroll end date and Last date worked.
Ensure you set date fields as “01/01/9999”. 

Step 3: Set Rule Context Onboarding = yes and other context = No. 

User steps to perform Cancel Onboarding

  • If Cancel Onboarding is performed after completing “New Hire Data review” step

If user have completed “New Hire Data review” step, then above-mentioned rule would have been executed.

  1. Login as Manager or Participant
  2. Navigate to Onboarding Dashboard.
  3. View All tasks/View Details.
  4. Actions Cancel
  • If “New Hire Data Review’ task is not configured in a process and Cancel Onboarding needs to be performed
  1. Login as Manager or Participant
  2. Navigate to Onboarding Dashboard.
  3. View All tasks/View Details.
  4. Actions à Jump to à New Hire Data page.
  5. Click “Continue” till you get “Submit” button.

This step will make sure Rule set in above gets executed and mandatory fields are populated and take action as “Cancel”

Note: This rule will NOT be executed as soon as Onboarding is initiated. Please follow section - User steps to perform Cancel Onboarding for more details

See Also

Keywords

onboarding processes, archive onboarding, mandatory fields, custom-string16, custom-string85, custom-string86, cancel onboarding, external candidate, onboarding job, data issue, SAP SuccessFactors , KBA , LOD-SF-OBX-DBD , Dashboard , Problem

Product

SAP SuccessFactors Onboarding 2511