Symptom
After an Instance Restore operation is performed on a SF tenant, the People Search (Directory Search / Enhanced People Search) returns an application error. Users are unable to search for colleagues by name or username.
Example:
- “Application error” is displayed when performing a People Search / Directory Search.
- Search results fail to load after the instance refresh or restore activity.
Environment
SAP SuccessFactors HCM Suite
Reproducing the Issue
- Perform an Instance Restore activity on a SAP SuccessFactors tenant where Enhanced People Search is enabled.
- Once the restore process is completed, log in to the restored instance.
- Navigate to People Search / Directory Search. Search for any user using name or username.
- Observe that the search fails and an “Application error” message is displayed instead of returning search results.
Cause
- During an Instance Refresh / Restore activity, the tenant is temporarily disconnected from the Enhanced People Search indexing service as part of the standard restore process. This is expected system behavior.
- Currently, after the refresh/restore is completed, the re-indexing process is not triggered automatically. As a result, the search indexes required for People Search / Directory Search may not be available immediately after the restore.Because of this, users may experience an “Application error” when attempting to search for employees until the tenant is re-onboarded and the search indexes are rebuilt.
Resolution
- A code fix is currently under development to ensure that the Instance Refresh/Restore pipeline automatically triggers the re-onboarding process in Platform Search after the restore activity is completed.This KBA will be updated with the patch deployment information once the fix is confirmed and scheduled for release.
- To stay informed about updates related to this issue, click the star icon to bookmark this article and subscribe for notifications.For more information about notifications for updated SAP Notes or KBAs, refer to KBA 2171560 - How to be notified of new or updated SAP Notes or KBAs.
- If you are currently experiencing this issue, please create a support case under component LOD-SF-PLT-SRH.
(Support teams: Please review the internal memo for recommended workaround instructions and next steps prior proceeding)
See Also
Keywords
KI1H2026,Application error in Enhanced people Search, application error searching user, user search error , application error post instance refresh , ISH-29599,INC27122144 ,User Search Error, Search Failure , KBA , LOD-SF-PLT-SRH , Search , Problem
Product
SAP SuccessFactors HCM Core 2605
SAP Knowledge Base Article - Public